puter/classes/headless/promtail.nix
2025-03-25 20:20:05 +01:00

43 lines
937 B
Nix

# {config, ...}: {
# services.promtail = {
# enable = true;
#
# configuration = {
# server = {
# http_listen_port = 3031;
# grpc_listen_port = 0;
# };
#
# positions = {
# filename = "/tmp/positions.yaml";
# };
#
# clients = [
# {
# url = "http://127.0.0.1:${toString config.services.loki.configuration.server.http_listen_port}/loki/api/v1/push";
# }
# ];
#
# scrape_configs = [
# {
# job_name = "journal";
# journal = {
# max_age = "12h";
# labels = {
# job = "systemd-journal";
# host = "pihole";
# };
# };
# relabel_configs = [
# {
# source_labels = ["__journal__systemd_unit"];
# target_label = "unit";
# }
# ];
# }
# ];
# };
# };
# }
{}